読者です 読者をやめる 読者になる 読者になる

python-tokyotyrant rev.19

Python

Tokyo Tyrant 1.1.9で、trcdbputrttがtrcdbputshlに改名されたので、これに合わせてpython-tokyotyrantも変更。rev.19以降は、TT 1.1.9以上でないとビルドできないはずです。

本当はバージョンを見て判断するようにすればいいのでしょうが、setup.pyやPyrexでどう書けばいいのか分からなかったので、あっさり妥協。このライブラリを使っている人がいるのかどうかは分かりませんが、いたとしても「使うのは常に開発版」「オープンソースプロジェクトのコミットログを読むのが三度の飯より好き」という心意気のある人だけに違いないので全く問題なし。

ただ最近はlibtokyotyrantを使う必要性もないかなと思い始めたので、近い将来にPure Python版も書くと思います。